Server error during installation (PHP Safe Mode)

We're upgrading our support forum. Replies are currently closed. Please view our Documentation and FAQ using the menu above.

Hi, we unable to install your script. I have to say that your documentation is really weak. You have to include a manuel to installation package.

Please comment our ERROR_log:

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20090626/’ – /usr/local/lib/php/extensions/no-debug-non-zts-20090626/: cannot read file data: Is a directory in Unknown on line 0

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/includes/config.php on line 20

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/includes/config.php on line 21

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 9

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 10

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 13

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  glob() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 31

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  Invalid argument supplied for foreach() in /home/XXX/public_html/backoffice/init.php on line 31

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  glob() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 55

[22-Mar-2013 05:04:47 America/Chicago] PHP Warning:  Invalid argument supplied for foreach() in /home/XXX/public_html/backoffice/init.php on line 55

[22-Mar-2013 05:04:47 America/Chicago] PHP Fatal error:  Class ‘module_config’ not found in /home/XXX/public_html/backoffice/init.php on line 79

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-non-zts-20090626/’ – /usr/local/lib/php/extensions/no-debug-non-zts-20090626/: cannot read file data: Is a directory in Unknown on line 0

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/includes/config.php on line 20

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/includes/config.php on line 21

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 9

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 10

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  ini_set() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 13

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  glob() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 31

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  Invalid argument supplied for foreach() in /home/XXX/public_html/backoffice/init.php on line 31

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  glob() has been disabled for security reasons in /home/XXX/public_html/backoffice/init.php on line 55

[22-Mar-2013 05:04:50 America/Chicago] PHP Warning:  Invalid argument supplied for foreach() in /home/XXX/public_html/backoffice/init.php on line 55

[22-Mar-2013 05:04:50 America/Chicago] PHP Fatal error:  Class ‘module_config’ not found in /home/XXX/public_html/backoffice/init.php on line 79

 

Hi, there is a manual installation script. unzip old_slow_installer.zip and use this instead of automatic install.

If like me at the end of the installation Style sheets doesnt work, do this :

Please open the file “includes/config.php” and on about line 19 you should see this: define(“_REWRITE_LINKS”,true); change it to this define(“_REWRITE_LINKS”,false);   old manual installation, worked fine for me.

Hope that helps.

Amar Bou

Hello,

Unfortunately I do not think this hosting account is compatible with UCM. Please send an email to the hosting provider asking if they can turn off “safe mode” and assist with script installation.

Thanks,
dtbaker

Hello,

First of all the server is our server. And my team manage it. We currently host 300+ company at our server. So they are running thousands scripts. Many of there are open-source scripts as web hosting nature. I have to say that your script has some vulnerabilities.

I can offer two options to chose one for help us,

1- Refund our payment to our Evanto account.

2- Fix your issues and install it. (We can share the cPanel credentials)

 

Best Regards,

Ugur.

 

Excellent! It’s always great when people manage their own servers. They can change configurations to make software work.

This script requires the php function glob() to operate, please enable this function on this particular hosting account to use UCM. The easiest way to enable glob would be to disable php safe mode for this particular hosting account.

It’s always good to disable php safe mode, it is no longer supported and will be removed shortly. There are more secure methods available (please see php website for more details: http://php.net/manual/en/features.safe-mode.php  )

Thanks,
dtbaker

Also to make use of the automated installer and the automated upgrade process please ensure the hosting account has access to the “zip_open” function (or alternatively the “passthru” function with zip shell access).

And in order to use the support ticketing function of UCM please also ensure the php imap extension (eg: imao_open function) is made available, sometimes this is disabled when safe_mode is turned on.

If your server has support for manual vhost entries then you can try disabling php safe_mode by adding this line inside the <VirtualHost> directive:

php_admin_flag safe_mode off 

Or sometimes there is an option in cPanel > “Service Configuration” > “PHP Configuration Manager” > “Safe Mode” change to Off.

Best of luck!

Hi DTbaker team,

Thank you for your quick response. I will try to disable php safe mode at this account. I will update here in a couple of hours.

Regards,

Ugur,

Hi again, I forward this details to my team. They said that safe mode is already off on our server and this account so.

What is your other advices?

 

Note: Also zip_open and php imap extensions are enabled.

Excellent!

Please enable the glob() function and the UCM system should function.

For best results please also enable the ini_set() function for this hosting account.

Thanks,
dtbaker

Hi, yes glob function was disabled for our disabling unnecessary functions procedure. Now the script working fine. Thank you for your support.

But now we have a different issue that the installation suppose that the installation try to install multiple account:

Sorry, the automated upgrade system has detected this single-use licence has been used on multiple installations:

client.DOMAIN/
DOMAIN/client/

How can we fix it?

Best Regards,

Ugur.

 

Yes please send in an email support ticket with the purchase code and we can very easily fix this for you.

Thank you for your support.

Best Regards,

Ugur.

Can you give us a how to link about language file editing. We have to translate the script.

 

Best,

Ugur.

The forum ‘Installation Support’ is closed to new topics and replies.

ugurterziServer error during installation (PHP Safe Mode)