Random Issues after install

We're upgrading our support forum. Replies are currently closed. Please view our Documentation and FAQ using the menu above.

Hello I am just getting started with this and am having some issues…

from the admin section on a customer account in the invoice tab:

Send Ivoice:

Email Invoice: does not work – links to a blank page with text  Email Invoice: 101

bottom of page links:

email same issue as above…

print pdf goes to generating pdf page and nothing happens.

Looking at the error_log:

PHP Fatal error:  Out of memory (allocated 39059456) (tried to allocate 87 bytes)

/includes/plugin_pdf/html2ps/value.border.edge.class.php on line 83

/includes/plugin_pdf/html2ps/value.border.class.php on line 24

/includes/plugin_pdf/html2ps/value.max-height.php on line 20

 

Can anyone help?

Thanks!

@dtbaker

I forgot to mention that I had already tried that…

Now playing around somemore I just created a subscription linked customer to it. then clicked email and whoala it worked… then I clicked on print pdf and it worked. Shocked!

ok then went back to the other invoice created earlier and tried the same things and it doesn’t work. [crap]

However I am excited I got to see the first invoice finally.

 

By the way… This is completly awesome program! Now I just need to learn how to use it!

Glad it is almost working. Please send this message to your hosting provider to see if they can assist:

“Hello, my error log is reporting this message when I am trying to generate a basic PDF using PHP:
PHP Fatal error:  Out of memory (allocated 39059456) (tried to allocate 87 bytes)
Is it possible to increase the memory limit on this hosting account so that I may use this script?”

Thanks,

dtbaker

Great I will send that request off and will be in touch thanks for the quick support. Fantastic!

This is resolved and working… !  

 

Incase anyone wants to know the fix this was the issue:

From Hosting Provider:

After some digging, we found that cPanel puts a specific memory limit within
Apache’s configuration:

grep -i rlimit /usr/local/apache/conf/httpd.conf
RLimitMEM 178956970

This setting was preempting every other memory limit set for php, at a
kernel/per-process level.

After fixing this, your application properly gives me a PDF. 

thanks again for your help!

The forum ‘Installation Support’ is closed to new topics and replies.

maximtalRandom Issues after install