mPDF error

We're upgrading our support forum. Replies are currently closed. Please view our Documentation and FAQ using the menu above.

Tagged: 

I keep getting an error every time i try to print pfd quotes i get this

“Error – mPDF requires mb_string functions. Ensure that PHP is compiled with php_mbstring.dll enabled.”

can anyone be helpful?

Looks like you don’t have mbstring enabled in php on your server.

Do you run your own server so therefore have root access, or are you on shared hosting?

If you have root access here’s a few pointers:

Video: https://www.youtube.com/watch?v=YDBfOQafXNc
Text: http://stackoverflow.com/questions/10278561/how-to-install-php-mbstring-on-centos-6-2

If you’re on shared then you’ll need to request your server administrator to do it for you.

I run my own VPS Server

Great!

You’ll be able to enable it yourself then 🙂

i get this error now

IMAGE Error (http://www.test.com/images/logo.png): GD library required for PNG image (alpha channel)

Just install GD Library as well then… 🙂

Can i install it thru WHM?

Yeah, in the exhaustive list when configuring PHP, there will be a checkbox for GD Library.

http://forums.cpanel.net/f5/php-gd-library-124161.html

Or you could do it with SSH…

Thanks that was real helpfull!

No worries, glad you got yourself sorted…

It sounds like David is updating UCM to work with PDO, you might want to look at enabling that as well in the exhaustive list – if you haven’t already got it checked?

Chances are you’ll run into more errors if not 😉

http://ultimateclientmanager.com/forums/topic/php-5-5-upgrade-deprecates-mysql/

Thanks James! BTW do you work with David?

No mate, I’m nothing to do with UCM/David. Just used it for many years now so try to help out where I can.

David supports UCM very well and has implemented lots of suggestions/ideas over the years so I just give back by helping where I can 🙂

have you done custom coding in UCM?

No, have no real need to do so.

It might be something I look at in the future but not right now…

If you have cPanel, enabling mbstring is very easy, you need to log into WHM/cPanel and under software you will find the Easy Apache Application:

EasyApache 101:

1. You can access EasyApache by going to the Software section of WHM and clicking on EasyApache. Command-line folks can just use /scripts/easyapache.

2. If you’re asked to update, do so then come back to this screen. (Updates often contain enhancements to allow EasyApache to support updated technologies.)

3. On the first screen (“1. Profile”), select “Previously Saved Config (** DEFAULT **)” and then click on the little gear icon to customise Apache.

This setting will display your current settings throughout the rest of the EasyApache interface. This way you don’t need to lookup what your current configuration is, you just change the items you want to have changed (e.g. adding mbstring support to PHP)

4. Continue clicking “Next” until you get to “5. Short Options List” then click “Exhaustive Options List” at the bottom of the page.

5. Under PHP, check the checkboxes for “mbstring” then click “Save and Build”

6. Follow any further on-screen instructions that appear.

The cool thing about EasyApache is that it will ensure everything will work before attempting to apply it to your server. In the relatively rare event that something fails, your current configuration is restored.

Hope this helps anyone else who gets the dreaded error message.

Just to add some info in case other people have this issue and want a quick fix, if they run their own linux server which has yum (and apache!) can easily add mbstring

yum install php-mbstring
and restart apache 😉

This mbstring missing was giving me blank pages when trying to send a user a notification of ticket assign – notify email.

The forum ‘General Support’ is closed to new topics and replies.

smoramPDF error