Changing Task Hours Error - invoice is $0

We're upgrading our support forum. Replies are currently closed. Please view our Documentation and FAQ using the menu above.

I’ve created a product with a quantity of 1 = $190. When I create a new job and select the product in the job tasks description everything appears to work fine.

But when I change the quantity to 2 units, then the amount automatically changes to $120, instead of 2 x $190 = $380.

Am I missing something?

Jimmy

It looks like it may pulling the data from the hourly rate section under ‘job details’ then multiplying. I had the price set for the product itself but this is being overwritten.

Hey Jimmy,

We have been working on a new big update that should improve this feature. Originally UCM was designed for an “Hours” and “Hourly Rate” only (that’s all I did) but it should now support other methods nicer (as of a few minutes ago).

I think the new option you will want to try is the “Qty and Amount” one.

More in this blog post:

http://ultimateclientmanager.com/2013/03/25/job-task-type-hours-quantity-or-just-amount/

 

Please let me know if you find any problems with this brand new feature.

Thanks,
dtbaker

Mate you are incredible! Thank you.

I’ve run an update and I’m looking for this feature but can’t find it.  Can you advise where the setting is located?

I can see it in the invoice section but not in the job section.

Please open an existing job and look in the “Advanced” section for “Task Type” (3rd from the bottom left).

Please see the online demo here for an example:

http://ultimateclientmanager.com/demo/job.job_admin?job_id=179

Also when clicking edit on individual tasks there is an option to adjust the “Task Type” per task if they need to differ from the overall job.

Thanks DT but I’m still a lost.

I have an existing product that I’ve set a price of $190 for.

When I create a new job, on the right side I have job tasks. I select the product from the drop down list and it comes up 1 hour cost $190. The hourly rate on the left “job details’ column is set to $0. I imagine I can substitute hours for quantity so I change the hours on the job task to 2 hours, then I create the task.

The task then comes up as $190 +GST. If the job is $190 per hour and I change it to 2 hours shouldn’t it be $380+GST?

Do I need to create the task then, go to the invoice and change everything so that it’s correct?

Thanks for your help – sorry I’m not understanding.

Jimmy

 

 

OK, after I enter then new task then the additional options come up at the bottom of the left job details column. I see the option you’ve nominated and can make the change and get the correct result.

Is it possible to set “quantity & amount’ as a system setting rather than have to change it here? In my case it would be ideal to have ‘quantity & amount’ as the default setting.

The calculation on the right side is always wrong until I enter the task then go down and change the setting.

Have just followed a test job through to the end and am getting an error with the invoice. I mark the job as completed and click “create a $418.00 invoice”. When the invoice then appears it’s for $0.00.

Hi Jimmy,

Yes we’ll make that option possible when creating jobs in the next update.

Could you please generate that same Job and Invoice in the online demo so I can see the problem and provide a fix: http://ultimateclientmanager.com/demo

Alternatively please send through an email support ticket and we can login to your UCM system to investigate the $0 invoice.

Thanks,
dtbaker

Thanks DT, I’ll give the demo option a run and see how we go.

DT,

 

I just ran the same process on the demo and it worked properly. I ran the process again on my version and again the $200 job generated a $0 invoice.

One difference I saw on the demo was that the task field showed QUANTITY by default, as opposed to my having to create the task as hours, save then change to QUANTITY. I typically change the hours field on the left to zero.

Perhaps this is over-riding the right?

Thanks for the extra information, I’ll try that a few more times here and try to locate the issue.

Thanks DT, I’ve also filed a support request with my log-in details, etc.

 

Hello DT,

Sorry to communicate through here and email but maybe a temporary solution is to change the priority to quantity in the first instance until a better fix is found.

My reasoning is that even if you charge hourly fees, you can still set them up as a product and sell them. Eg;

Product 1 = 1 hour @ $250

Product 2 = 1.5 hour @ $320

etc

This may not be the best fix but perhaps it can spark some other ideas. I can’t imagine the hourly guys would be too keen to change their setups.

Please try the latest update and see if that resolves the $0 invoice amount.

New update has fixed the issue – thanks DT. Do you plan to add a  quantity v’s hours default option in future upgrades?

The forum ‘General Support’ is closed to new topics and replies.

Jimmy ChickensChanging Task Hours Error – invoice is $0