We're upgrading our support forum. Replies are currently closed. Please view our Documentation and FAQ using the menu above.

Under “Customer Data Access” try selecting “only customers I am assigned to as contact”. See if that works. That is the setting I use and it works for me. The other settings look the same with my client account.

savioReply To: Limit customer to only view his invoice and job in the system